CVE-2016-2524

NameCVE-2016-2524
Descriptionepan/dissectors/packet-x509af.c in the X.509AF dissector in Wireshark 2.0.x before 2.0.2 mishandles the algorithm ID, which allows remote attackers to cause a denial of service (application crash) via a crafted packet.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)stretch (security), stretch2.6.7-1~deb9u1fixed
buster2.6.8-1.1fixed
bullseye3.2.6-1fixed
sid3.2.7-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksourcesqueeze(not affected)
wiresharksourcewheezy(not affected)
wiresharksourcejessie(not affected)
wiresharksource(unstable)2.0.2+ga16e22e-1

Notes

[jessie] - wireshark <not-affected> (Only affects 2.0.x)
[wheezy] - wireshark <not-affected> (Only affects 2.0.x)
[squeeze] - wireshark <not-affected> (Only affects 2.0.x)
https://www.wireshark.org/security/wnpa-sec-2016-04.html
Affected versions: 2.0.0 to 2.0.1
Fixed versions: 2.0.2

Search for package or bug name: Reporting problems