CVE-2016-2525

NameCVE-2016-2525
Descriptionepan/dissectors/packet-http2.c in the HTTP/2 dissector in Wireshark 2.0.x before 2.0.2 does not limit the amount of header data, which allows remote attackers to cause a denial of service (memory consumption or application crash) via a crafted packet.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)buster2.6.20-0+deb10u4fixed
buster (security)2.6.20-0+deb10u7fixed
bullseye (security), bullseye3.4.10-0+deb11u1fixed
bookworm, bookworm (security)4.0.6-1~deb12u1fixed
sid, trixie4.0.8-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksourcewheezy(not affected)
wiresharksourcejessie(not affected)
wiresharksource(unstable)2.0.2+ga16e22e-1

Notes

[jessie] - wireshark <not-affected> (Vulnerable code not present)
[wheezy] - wireshark <not-affected> (Vulnerable code not present)
https://www.wireshark.org/security/wnpa-sec-2016-05.html
Affected versions: 2.0.0 to 2.0.1
Fixed versions: 2.0.2

Search for package or bug name: Reporting problems