CVE-2016-2533

NameCVE-2016-2533
DescriptionBuffer overflow in the ImagingPcdDecode function in PcdDecode.c in Pillow before 3.1.1 and Python Imaging Library (PIL) 1.1.7 and earlier allows remote attackers to cause a denial of service (crash) via a crafted PhotoCD file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-422-1, DSA-3499-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pillow (PTS)jessie (security), jessie2.6.1-2+deb8u3fixed
stretch4.0.0-4fixed
buster4.2.1-1fixed
sid4.3.0-1fixed
python-imaging (PTS)wheezy1.1.7-4+deb7u2fixed
wheezy (security)1.1.7-4+deb7u3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pillowsource(unstable)3.1.1-1medium
pillowsourcejessie2.6.1-2+deb8u2mediumDSA-3499-1
python-imagingsource(unstable)(unfixed)medium
python-imagingsourcesqueeze1.1.7-2+deb6u2mediumDLA-422-1
python-imagingsourcewheezy1.1.7-4+deb7u2medium

Notes

https://github.com/python-pillow/Pillow/pull/1706
http://www.openwall.com/lists/oss-security/2016/02/02/5
https://github.com/python-pillow/Pillow/commit/ae453aa18b66af54e7ff716f4ccb33adca60afd4

Search for package or bug name: Reporting problems