CVE-2016-2540

NameCVE-2016-2540
DescriptionAudacity before 2.1.2 allows remote attackers to cause a denial of service (memory corruption and application crash) via a crafted FORMATCHUNK structure.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1277-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
audacity (PTS)wheezy2.0.1-1vulnerable
wheezy (security)2.0.1-1+deb7u1fixed
jessie2.0.6-2vulnerable
stretch2.1.2-2fixed
buster, sid2.2.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
audacitysource(unstable)2.1.2-1
audacitysourcewheezy2.0.1-1+deb7u1DLA-1277-1

Notes

http://wiki.audacityteam.org/wiki/Release_Notes_2.1.2
https://github.com/audacity/audacity/commit/407c1dc4b209111e4dbb3eec88f333aa8f69094c
https://github.com/audacity/audacity/commit/b5f2046286b266b10f87b764faa1586aee9c23ea

Search for package or bug name: Reporting problems