CVE-2016-2554

NameCVE-2016-2554
DescriptionStack-based buffer overflow in ext/phar/tar.c in PHP before 5.5.32, 5.6.x before 5.6.18, and 7.x before 7.0.3 allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a crafted TAR archive.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-818-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php7.0 (PTS)stretch7.0.33-0+deb9u8fixed
stretch (security)7.0.33-0+deb9u12fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5sourcewheezy5.4.45-0+deb7u7DLA-818-1
php5sourcejessie5.6.19+dfsg-0+deb8u1
php5source(unstable)5.6.18+dfsg-1
php5.6source(unstable)5.6.18+dfsg-1
php7.0source(unstable)7.0.3-1

Notes

[wheezy] - php5 <no-dsa> (Minor issue, can be fixed in next update round)
https://bugs.php.net/bug.php?id=71488
https://bugzilla.redhat.com/show_bug.cgi?id=1305543
https://git.php.net/?p=php-src.git;a=commit;h=07c7df68bd68bbe706371fccc77c814ebb335d9e
Fixed in 5.6.18, 5.5.32, 7.0.3
https://www.openwall.com/lists/oss-security/2016/02/22/5

Search for package or bug name: Reporting problems