CVE-2016-2563

NameCVE-2016-2563
DescriptionStack-based buffer overflow in the SCP command-line utility in PuTTY before 0.67 and KiTTY 0.66.6.3 and earlier allows remote servers to cause a denial of service (stack memory corruption) or execute arbitrary code via a crafted SCP-SINK file-size response to an SCP download request.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs816921

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
putty (PTS)stretch (security), stretch0.67-3+deb9u1fixed
buster0.70-6fixed
bullseye0.74-1fixed
bookworm, sid0.76-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
puttysource(unstable)0.67-1816921

Notes

[jessie] - putty <no-dsa> (Minor issue)
[wheezy] - putty <no-dsa> (Minor issue)
http://www.chiark.greenend.org.uk/~sgtatham/putty/wishlist/vuln-pscp-sink-sscanf.html
https://git.tartarus.org/?p=simon/putty.git;a=commitdiff;h=bc6c15ab5f636e05b7e91883f0031a7e06117947
https://github.com/tintinweb/pub/tree/master/pocs/cve-2016-2563

Search for package or bug name: Reporting problems