DescriptionStack-based buffer overflow in the SCP command-line utility in PuTTY before 0.67 and KiTTY and earlier allows remote servers to cause a denial of service (stack memory corruption) or execute arbitrary code via a crafted SCP-SINK file-size response to an SCP download request.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs816921

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
putty (PTS)buster0.70-6fixed
buster (security)0.74-1+deb11u1~deb10u2fixed
bullseye (security), bullseye0.74-1+deb11u1fixed
bookworm, bookworm (security)0.78-2+deb12u1fixed
sid, trixie0.81-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs


[jessie] - putty <no-dsa> (Minor issue)
[wheezy] - putty <no-dsa> (Minor issue);a=commitdiff;h=bc6c15ab5f636e05b7e91883f0031a7e06117947

Search for package or bug name: Reporting problems