CVE-2016-2571

NameCVE-2016-2571
Descriptionhttp.cc in Squid 3.x before 3.5.15 and 4.x before 4.0.7 proceeds with the storage of certain data after a response-parsing failure, which allows remote HTTP servers to cause a denial of service (assertion failure and daemon exit) via a malformed response.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-445-1, DSA-3522-1
NVD severitymedium (attack range: remote)
Debian Bugs816011

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
squid (PTS)wheezy2.7.STABLE9-4.1+deb7u1fixed
wheezy (security)2.7.STABLE9-4.1+deb7u2fixed
squid3 (PTS)wheezy3.1.20-2.2+deb7u4fixed
wheezy (security)3.1.20-2.2+deb7u7fixed
jessie (security), jessie3.4.8-6+deb8u4fixed
buster, sid, stretch3.5.23-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
squidsource(unstable)(not affected)
squid3source(unstable)3.5.15-1medium816011
squid3sourcejessie3.4.8-6+deb8u2mediumDSA-3522-1
squid3sourcesqueeze3.1.6-1.2+squeeze6mediumDLA-445-1
squid3sourcewheezy3.1.20-2.2+deb7u4mediumDSA-3522-1

Notes

- squid <not-affected> (Vulnerable code not present)
http://www.squid-cache.org/Advisories/SQUID-2016_2.txt
http://www.squid-cache.org/Versions/v3/3.5/changesets/squid-3.5-13990.patch
http://www.squid-cache.org/Versions/v4/changesets/squid-4-14548.patch
Upstream confirmed it does not affect squid 2.7.x

Search for package or bug name: Reporting problems