CVE-2016-2774

NameCVE-2016-2774
DescriptionISC DHCP 4.1.x before 4.1-ESV-R13 and 4.2.x and 4.3.x before 4.3.4 does not restrict the number of concurrent TCP sessions, which allows remote attackers to cause a denial of service (INSIST assertion failure or request-processing outage) by establishing many sessions.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs817158

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
isc-dhcp (PTS)jessie (security), jessie4.3.1-6+deb8u3vulnerable
stretch (security), stretch4.3.5-3+deb9u1fixed
buster, sid4.4.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
isc-dhcpsource(unstable)4.3.4-1high817158

Notes

[jessie] - isc-dhcp <no-dsa> (Minor issue)
[wheezy] - isc-dhcp <no-dsa> (Minor issue)
https://kb.isc.org/article/AA-01354
https://source.isc.org/cgi-bin/gitweb.cgi?p=dhcp.git;a=commitdiff;h=0b209ea5cc333255e055113fa2ad636dda681a21

Search for package or bug name: Reporting problems