CVE-2016-2776

NameCVE-2016-2776
Descriptionbuffer.c in named in ISC BIND 9 before 9.9.9-P3, 9.10.x before 9.10.4-P3, and 9.11.x before 9.11.0rc3 does not properly construct responses, which allows remote attackers to cause a denial of service (assertion failure and daemon exit) via a crafted query.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-645-1, DSA-3680-1
NVD severityhigh
Debian Bugs839010

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
bind9 (PTS)jessie1:9.9.5.dfsg-9+deb8u15fixed
jessie (security)1:9.9.5.dfsg-9+deb8u18fixed
stretch (security), stretch1:9.10.3.dfsg.P4-12.3+deb9u5fixed
buster1:9.11.5.P4+dfsg-5.1fixed
bullseye, sid1:9.11.14+dfsg-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
bind9source(unstable)1:9.10.3.dfsg.P4-11839010
bind9sourceexperimental1:9.10.4-P5-1
bind9sourcejessie1:9.9.5.dfsg-9+deb8u7DSA-3680-1
bind9sourcewheezy1:9.8.4.dfsg.P1-6+nmu2+deb7u11DLA-645-1

Notes

https://kb.isc.org/article/AA-01419

Search for package or bug name: Reporting problems