CVE-2016-2821

NameCVE-2016-2821
DescriptionUse-after-free vulnerability in the mozilla::dom::Element class in Mozilla Firefox before 47.0 and Firefox ESR 45.x before 45.2, when contenteditable mode is enabled, allows remote attackers to execute arbitrary code or cause a denial of service (heap memory corruption) by triggering deletion of DOM elements that were created in the editor.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-521-1, DSA-3600-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid71.0-2fixed
firefox-esr (PTS)jessie52.8.1esr-1~deb8u1fixed
jessie (security)68.3.0esr-1~deb8u1fixed
stretch60.7.1esr-1~deb9u1fixed
stretch (security)68.3.0esr-1~deb9u1fixed
buster68.2.0esr-1~deb10u1fixed
buster (security)68.3.0esr-1~deb10u1fixed
bullseye68.2.0esr-1fixed
sid68.3.0esr-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)47.0-1
firefox-esrsource(unstable)45.2.0esr-1
firefox-esrsourcejessie45.2.0esr-1~deb8u1DSA-3600-1
firefox-esrsourcewheezy45.2.0esr-1~deb7u1DLA-521-1

Search for package or bug name: Reporting problems