CVE-2016-2860

NameCVE-2016-2860
DescriptionThe newEntry function in ptserver/ptprocs.c in OpenAFS before 1.6.17 allows remote authenticated users from foreign Kerberos realms to bypass intended access restrictions and create arbitrary groups as administrators by leveraging mishandling of the creator ID.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-493-1, DSA-3569-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openafs (PTS)wheezy1.6.1-3+deb7u5vulnerable
wheezy (security)1.6.1-3+deb7u7fixed
jessie (security), jessie1.6.9-2+deb8u5fixed
stretch1.6.20-2fixed
buster, sid1.6.22-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openafssource(unstable)1.6.17-1medium
openafssourcejessie1.6.9-2+deb8u5mediumDSA-3569-1
openafssourcewheezy1.6.1-3+deb7u6mediumDLA-493-1

Notes

http://git.openafs.org/?p=openafs.git;a=commitdiff;h=396240cf070a806b91fea81131d034e1399af1e0
http://rt.central.org/rt/Ticket/Display.html?id=132822 (currently not public)

Search for package or bug name: Reporting problems