CVE-2016-3068

NameCVE-2016-3068
DescriptionMercurial before 3.7.3 allows remote attackers to execute arbitrary code via a crafted git ext:: URL when cloning a subrepository.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3542-1
NVD severitymedium
Debian Bugs819504

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mercurial (PTS)stretch4.0-1+deb9u1fixed
stretch (security)4.0-1+deb9u2fixed
buster4.8.2-1+deb10u1fixed
bullseye, sid5.6.1-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mercurialsourcewheezy2.2.2-4+deb7u2DSA-3542-1
mercurialsourcejessie3.1.2-2+deb8u2DSA-3542-1
mercurialsource(unstable)3.7.3-1819504

Notes

https://www.mercurial-scm.org/wiki/WhatsNew#Mercurial_3.7.3_.282016-3-29.29
https://selenic.com/repo/hg-stable/rev/34d43cb85de8

Search for package or bug name: Reporting problems