CVE-2016-3069

NameCVE-2016-3069
DescriptionMercurial before 3.7.3 allows remote attackers to execute arbitrary code via a crafted name when converting a Git repository.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3542-1
NVD severitymedium (attack range: remote)
Debian Bugs819504

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mercurial (PTS)wheezy2.2.2-4+deb7u2fixed
wheezy (security)2.2.2-4+deb7u5fixed
jessie3.1.2-2+deb8u3fixed
jessie (security)3.1.2-2+deb8u4fixed
stretch (security), stretch4.0-1+deb9u1fixed
buster, sid4.3.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mercurialsource(unstable)3.7.3-1medium819504
mercurialsourcejessie3.1.2-2+deb8u2mediumDSA-3542-1
mercurialsourcewheezy2.2.2-4+deb7u2mediumDSA-3542-1

Notes

https://www.mercurial-scm.org/wiki/WhatsNew#Mercurial_3.7.3_.282016-3-29.29
https://selenic.com/repo/hg-stable/rev/197eed39e3d5 (1/5)
https://selenic.com/repo/hg-stable/rev/cdda7b96afff (2/5)
https://selenic.com/repo/hg-stable/rev/b732e7f2aba4 (3/5)
https://selenic.com/repo/hg-stable/rev/80cac1de6aea (4/5)
https://selenic.com/repo/hg-stable/rev/ae279d4a19e9 (5/5)

Search for package or bug name: Reporting problems