CVE-2016-3076

NameCVE-2016-3076
DescriptionHeap-based buffer overflow in the j2k_encode_entry function in Pillow 2.5.0 through 3.1.1 allows remote attackers to cause a denial of service (memory corruption) via a crafted Jpeg2000 file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pillow (PTS)jessie (security), jessie2.6.1-2+deb8u3vulnerable
stretch4.0.0-4vulnerable
buster, sid5.2.0-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pillowsource(unstable)(unfixed)unimportant
python-imagingsource(unstable)(unfixed)unimportant

Notes

https://github.com/python-pillow/Pillow/commit/a1f244343df389cf15cdfff80327594821097295 (3.1.2)
Marked as unimportant since source vulnerable but in Debian we do
not built against openjpeg by default

Search for package or bug name: Reporting problems