CVE-2016-3092

NameCVE-2016-3092
DescriptionThe MultipartStream class in Apache Commons Fileupload before 1.3.2, as used in Apache Tomcat 7.x before 7.0.70, 8.x before 8.0.36, 8.5.x before 8.5.3, and 9.x before 9.0.0.M7 and other products, allows remote attackers to cause a denial of service (CPU consumption) via a long boundary string.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-528-1, DLA-529-1, DSA-3609-1, DSA-3611-1, DSA-3614-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libcommons-fileupload-java (PTS)jessie (security), jessie1.3.1-1+deb8u1fixed
stretch1.3.2-2fixed
bullseye, sid, buster1.3.3-1fixed
tomcat7 (PTS)jessie7.0.56-3+deb8u11fixed
jessie (security)7.0.56-3+really7.0.94-1fixed
stretch7.0.75-1fixed
tomcat8 (PTS)jessie8.0.14-1+deb8u11fixed
jessie (security)8.0.14-1+deb8u15fixed
stretch (security), stretch8.5.14-1+deb9u3fixed
tomcat9 (PTS)buster9.0.16-4fixed
bullseye, sid9.0.27-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libcommons-fileupload-javasource(unstable)1.3.2-1
libcommons-fileupload-javasourcejessie1.3.1-1+deb8u1DSA-3611-1
libcommons-fileupload-javasourcewheezy1.2.2-1+deb7u3DLA-528-1
tomcat7source(unstable)7.0.70-1
tomcat7sourcejessie7.0.56-3+deb8u3DSA-3614-1
tomcat7sourcewheezy7.0.28-4+deb7u5DLA-529-1
tomcat8source(unstable)8.0.36-1
tomcat8sourcejessie8.0.14-1+deb8u2DSA-3609-1
tomcat9source(unstable)(not affected)

Notes

- tomcat9 <not-affected> (Fixed before initial upload to Debian)
Fixed by https://svn.apache.org/r1743480
Upstream advisory http://markmail.org/message/oyxfv73jb2g7rjg3
https://mail-archives.us.apache.org/mod_mbox/www-announce/201606.mbox/%3C6223ece6-2b41-ef4f-22f9-d3481e492832@apache.org%3E

Search for package or bug name: Reporting problems