CVE-2016-3105

NameCVE-2016-3105
DescriptionThe convert extension in Mercurial before 3.8 might allow context-dependent attackers to execute arbitrary code via a crafted git repository name.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-459-1, DSA-3570-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mercurial (PTS)wheezy2.2.2-4+deb7u2vulnerable
wheezy (security)2.2.2-4+deb7u5fixed
jessie3.1.2-2+deb8u3fixed
jessie (security)3.1.2-2+deb8u4fixed
stretch (security), stretch4.0-1+deb9u1fixed
buster, sid4.3.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mercurialsource(unstable)3.8.1-1medium
mercurialsourcejessie3.1.2-2+deb8u3mediumDSA-3570-1
mercurialsourcewheezy2.2.2-4+deb7u3mediumDLA-459-1

Notes

https://selenic.com/hg/rev/a56296f55a5e

Search for package or bug name: Reporting problems