CVE-2016-3124

NameCVE-2016-3124
DescriptionThe sanitycheck module in SimpleSAMLphp before 1.14.1 allows remote attackers to learn the PHP version on the system via unspecified vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs817162

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
simplesamlphp (PTS)wheezy1.9.2-1vulnerable
wheezy (security)1.9.2-1+deb7u1vulnerable
jessie1.13.1-2vulnerable
stretch1.14.11-1fixed
buster1.15.0-1fixed
sid1.15.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
simplesamlphpsource(unstable)1.14.1-1unimportant817162

Notes

https://simplesamlphp.org/security/201603-01
Fixed upstream in 1.14.1
https://github.com/simplesamlphp/simplesamlphp/commit/952027dd7f794ff4b2d4f5eddf549c5b5070fa38
http://www.openwall.com/lists/oss-security/2016/03/08/4
Not treated as a security issue, many components in Debian reveal the release in use

Search for package or bug name: Reporting problems