CVE-2016-3125

NameCVE-2016-3125
DescriptionThe mod_tls module in ProFTPD before 1.3.5b and 1.3.6 before 1.3.6rc2 does not properly handle the TLSDHParamFile directive, which might cause a weaker than intended Diffie-Hellman (DH) key to be used and consequently allow attackers to have unspecified impact via unknown vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs818492

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
proftpd-dfsg (PTS)wheezy, wheezy (security)1.3.4a-5+deb7u3vulnerable
jessie1.3.5-1.1+deb8u2fixed
jessie (security)1.3.5-1.1+deb8u1vulnerable
stretch1.3.5b-4fixed
buster, sid1.3.5d-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
proftpd-dfsgsource(unstable)1.3.5b-1medium818492
proftpd-dfsgsourcejessie1.3.5-1.1+deb8u2medium

Notes

[wheezy] - proftpd-dfsg <no-dsa> (Minor issue; can be fixed in point release)
http://bugs.proftpd.org/show_bug.cgi?id=4230
Fixed in 1.3.6rc2, 1.3.5b.

Search for package or bug name: Reporting problems