CVE-2016-3141

NameCVE-2016-3141
DescriptionUse-after-free vulnerability in wddx.c in the WDDX extension in PHP before 5.5.33 and 5.6.x before 5.6.19 allows remote attackers to cause a denial of service (memory corruption and application crash) or possibly have unspecified other impact by triggering a wddx_deserialize call on XML data containing a crafted var element.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-818-1

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5sourcewheezy5.4.45-0+deb7u7DLA-818-1
php5sourcejessie5.6.19+dfsg-0+deb8u1
php5source(unstable)5.6.19+dfsg-1

Notes

[wheezy] - php5 <no-dsa> (Minor issue, can be fixed in next update round)
https://bugs.php.net/bug.php?id=71587
Fixed in 5.5.33, 5.6.19
https://www.openwall.com/lists/oss-security/2016/03/10/5
https://www.openwall.com/lists/oss-security/2016/03/13/1

Search for package or bug name: Reporting problems