CVE-2016-3153

NameCVE-2016-3153
DescriptionSPIP 2.x before 2.1.19, 3.0.x before 3.0.22, and 3.1.x before 3.1.1 allows remote attackers to execute arbitrary PHP code by adding content, related to the filtrer_entites function.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3518-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
spip (PTS)wheezy2.1.17-1+deb7u5fixed
wheezy (security)2.1.17-1+deb7u8fixed
jessie3.0.17-2+deb8u3fixed
jessie (security)3.0.17-2+deb8u2fixed
stretch (security), stretch3.1.4-3~deb9u1fixed
buster, sid3.1.4-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
spipsource(unstable)3.0.22-1high
spipsourcejessie3.0.17-2+deb8u2highDSA-3518-1
spipsourcewheezy2.1.17-1+deb7u5highDSA-3518-1

Notes

http://www.openwall.com/lists/oss-security/2016/03/15/2
patch https://core.spip.net/projects/spip/repository/revisions/22911

Search for package or bug name: Reporting problems