CVE-2016-3154

NameCVE-2016-3154
DescriptionThe encoder_contexte_ajax function in ecrire/inc/filtres.php in SPIP 2.x before 2.1.19, 3.0.x before 3.0.22, and 3.1.x before 3.1.1 allows remote attackers to conduct PHP object injection attacks and execute arbitrary PHP code via a crafted serialized object.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3518-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
spip (PTS)stretch3.1.4-4~deb9u3fixed
stretch (security)3.1.4-4~deb9u4+deb9u1fixed
buster, buster (security)3.2.4-1+deb10u4fixed
bookworm, sid, bullseye3.2.11-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
spipsourcewheezy2.1.17-1+deb7u5DSA-3518-1
spipsourcejessie3.0.17-2+deb8u2DSA-3518-1
spipsource(unstable)3.0.22-1

Notes

https://www.openwall.com/lists/oss-security/2016/03/15/2
patch https://core.spip.net/projects/spip/repository/revisions/22903

Search for package or bug name: Reporting problems