CVE-2016-3176

NameCVE-2016-3176
DescriptionSalt before 2015.5.10 and 2015.8.x before 2015.8.8, when PAM external authentication is enabled, allows attackers to bypass the configured authentication service by passing an alternate service with a command sent to LocalClient.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs819184

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
salt (PTS)jessie2014.1.13+ds-3vulnerable
stretch2016.11.2+ds-1+deb9u2fixed
buster2018.3.4+dfsg1-6fixed
sid2018.3.4+dfsg1-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
saltsource(unstable)2015.8.8+ds-1medium819184

Notes

[jessie] - salt <no-dsa> (Minor issue; external_auth not by default usable)
external_auth seems not usable by default under Jessie due to the
permissions on /var/run/salt/master.
https://docs.saltstack.com/en/latest/topics/releases/2015.8.8.html
https://docs.saltstack.com/en/latest/topics/releases/2015.5.10.html
https://github.com/saltstack/salt/pull/31826/commits/d73f70ebb289142e4f692359fe741a54f5d2ad65
Fixed in 2015.5.10/2015.8.8 upstream

Search for package or bug name: Reporting problems