CVE-2016-3179

NameCVE-2016-3179
DescriptionThe processRequest function in minissdpd.c in MiniSSDPd 1.2.20130907-3 allows local users to cause a denial of service (invalid free and daemon crash) via vectors related to error handling.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-454-1
NVD severitylow
Debian Bugs816759

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
minissdpd (PTS)stretch1.2.20130907-4.1+deb9u1fixed
buster1.5.20190210-1fixed
bookworm, sid, bullseye1.5.20190824-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
minissdpdsourcewheezy1.1.20120121-1+deb7u1DLA-454-1
minissdpdsourcejessie1.2.20130907-3+deb8u1
minissdpdsource(unstable)1.2.20130907-3.2816759

Notes

https://speirofr.appspot.com/files/advisory/SPADV-2016-02.md
https://github.com/miniupnp/miniupnp/commit/140ee8d2204b383279f854802b27bdb41c1d5d1a

Search for package or bug name: Reporting problems