CVE-2016-3190

NameCVE-2016-3190
DescriptionThe fill_xrgb32_lerp_opaque_spans function in cairo-image-compositor.c in cairo before 1.14.2 allows remote attackers to cause a denial of service (out-of-bounds read and application crash) via a negative span length.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cairo (PTS)jessie1.14.0-2.1+deb8u2fixed
stretch1.14.8-1fixed
buster, sid1.16.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cairosource(unstable)1.14.2-2medium
cairosourcejessie1.14.0-2.1+deb8u1medium

Notes

[wheezy] - cairo <no-dsa> (Minor issue)
https://cgit.freedesktop.org/cairo/patch/src/cairo-image-compositor.c?id=5c82d91a5e15d29b1489dcb413b24ee7fdf59934

Search for package or bug name: Reporting problems