CVE-2016-3621

NameCVE-2016-3621
DescriptionThe LZWEncode function in tif_lzw.c in the bmp2tiff tool in LibTIFF 4.0.6 and earlier, when the "-c lzw" option is used, allows remote attackers to cause a denial of service (buffer over-read) via a crafted BMP image.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-693-1
NVD severitymedium (attack range: remote)
Debian Bugs820364

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tiff (PTS)jessie4.0.3-12.3+deb8u5fixed
jessie (security)4.0.3-12.3+deb8u8fixed
stretch (security), stretch4.0.8-2+deb9u4fixed
bullseye, sid, buster4.0.10-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tiffsource(unstable)4.0.6-3low820364
tiffsourcejessie4.0.3-12.3+deb8u2medium
tiffsourcewheezy4.0.2-6+deb7u7mediumDLA-693-1
tiff3source(unstable)(not affected)

Notes

- tiff3 <not-affected> (tiff tools not built)
http://bugzilla.maptools.org/show_bug.cgi?id=2565
http://www.openwall.com/lists/oss-security/2016/04/07/3
Utility bmp2tiff has been removed from upstream LibTIFF
bmp2tiff was removed in 4.0.6-3 and DSA 3762, marking as fixed although technically still present in the source package

Search for package or bug name: Reporting problems