CVE-2016-3623

NameCVE-2016-3623
DescriptionThe rgb2ycbcr tool in LibTIFF 4.0.6 and earlier allows remote attackers to cause a denial of service (divide-by-zero) by setting the (1) v or (2) h parameter to 0.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-610-1, DLA-795-1, DSA-3762-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tiff (PTS)stretch (security), stretch4.0.8-2+deb9u5fixed
buster, buster (security)4.1.0+git191117-2~deb10u2fixed
bullseye, sid4.2.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tiffsourcewheezy4.0.2-6+deb7u9DLA-795-1
tiffsourcejessie4.0.3-12.3+deb8u2DSA-3762-1
tiffsource(unstable)4.0.6-3unimportant
tiff3sourcewheezy3.9.6-11+deb7u1DLA-610-1
tiff3source(unstable)(unfixed)unimportant

Notes

http://bugzilla.maptools.org/show_bug.cgi?id=2569
No security impact, just triggers a crash in a CLI tool

Search for package or bug name: Reporting problems