CVE-2016-3739

NameCVE-2016-3739
DescriptionThe (1) mbed_connect_step1 function in lib/vtls/mbedtls.c and (2) polarssl_connect_step1 function in lib/vtls/polarssl.c in cURL and libcurl before 7.49.0, when using SSLv3 or making a TLS connection to a URL that uses a numerical IP address, allow remote attackers to spoof servers via an arbitrary valid certificate.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
curl (PTS)wheezy7.26.0-1+wheezy13vulnerable
wheezy (security)7.26.0-1+wheezy23vulnerable
jessie, jessie (security)7.38.0-4+deb8u8vulnerable
stretch, stretch (security)7.52.1-5+deb9u3fixed
buster, sid7.57.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
curlsource(unstable)7.50.1-1unimportant

Notes

only relevant when built with mbedTLS/PolarSSL
Source-wise fixed in 7.49.0

Search for package or bug name: Reporting problems