CVE-2016-3948

NameCVE-2016-3948
DescriptionSquid 3.x before 3.5.16 and 4.x before 4.0.8 improperly perform bounds checking, which allows remote attackers to cause a denial of service via a crafted HTTP response, related to Vary headers.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3625-1
NVD severitymedium
Debian Bugs819784

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
squid (PTS)buster, buster (security)4.6-1+deb10u4fixed
bullseye, sid4.13-1fixed
squid3 (PTS)stretch3.5.23-5+deb9u1fixed
stretch (security)3.5.23-5+deb9u5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
squidsource(unstable)4.1-1
squid3sourcejessie3.4.8-6+deb8u3DSA-3625-1
squid3source(unstable)3.5.16-1819784

Notes

[wheezy] - squid3 <no-dsa> (Minor issue; needs substantial backporting; too intrusive to backport)
[wheezy] - squid <no-dsa> (Minor issue; needs substantial backporting; too intrusive to backport)
http://www.squid-cache.org/Versions/v3/3.5/changesets/squid-3.5-14016.patch
http://www.squid-cache.org/Advisories/SQUID-2016_4.txt

Search for package or bug name: Reporting problems