CVE-2016-3981

NameCVE-2016-3981
DescriptionHeap-based buffer overflow in the bmp_read_rows function in pngxrbmp.c in OptiPNG before 0.7.6 allows remote attackers to cause a denial of service (out-of-bounds read or write access and crash) or possibly execute arbitrary code via a crafted image file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3546-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
optipng (PTS)wheezy, wheezy (security)0.6.4-1+deb7u2fixed
jessie (security), jessie0.7.5-1+deb8u1fixed
buster, sid, stretch0.7.6-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
optipngsource(unstable)0.7.6-1high
optipngsourcejessie0.7.5-1+deb8u1highDSA-3546-1
optipngsourcewheezy0.6.4-1+deb7u2highDSA-3546-1

Notes

https://sourceforge.net/p/optipng/bugs/56/

Search for package or bug name: Reporting problems