CVE-2016-3994

NameCVE-2016-3994
DescriptionThe GIF loader in imlib2 before 1.4.9 allows remote attackers to cause a denial of service (application crash) or obtain sensitive information via a crafted image, which triggers an out-of-bounds read.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3555-1
NVD severitymedium (attack range: remote)
Debian Bugs785369

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
imlib2 (PTS)wheezy, wheezy (security)1.4.5-1+deb7u2fixed
jessie (security), jessie1.4.6-2+deb8u2fixed
buster, sid, stretch1.4.8-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
imlib2source(unstable)1.4.8-1medium785369
imlib2sourcejessie1.4.6-2+deb8u2mediumDSA-3555-1
imlib2sourcewheezy1.4.5-1+deb7u2mediumDSA-3555-1

Notes

https://git.enlightenment.org/legacy/imlib2.git/commit/?id=37a96801663b7b4cd3fbe56cc0eb8b6a17e766a8
http://www.openwall.com/lists/oss-security/2016/04/09/6

Search for package or bug name: Reporting problems