CVE-2016-4000

NameCVE-2016-4000
DescriptionJython before 2.7.1rc1 allows attackers to execute arbitrary code via a crafted serialized PyFunction object.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-989-1, DSA-3893-1
NVD severityhigh (attack range: remote)
Debian Bugs864859

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
jython (PTS)wheezy2.5.2-1vulnerable
wheezy (security)2.5.2-1+deb7u1fixed
jessie (security), jessie2.5.3-3+deb8u1fixed
stretch (security), stretch2.5.3-16+deb9u1fixed
buster, sid2.7.1+repack-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
jythonsource(unstable)2.5.3-17high864859
jythonsourcejessie2.5.3-3+deb8u1highDSA-3893-1
jythonsourcestretch2.5.3-16+deb9u1highDSA-3893-1
jythonsourcewheezy2.5.2-1+deb7u1highDLA-989-1

Notes

http://bugs.jython.org/issue2454
https://hg.python.org/jython/rev/d06e29d100c0

Search for package or bug name: Reporting problems