CVE-2016-4002

NameCVE-2016-4002
DescriptionBuffer overflow in the mipsnet_receive function in hw/net/mipsnet.c in QEMU, when the guest NIC is configured to accept large packets, allows remote attackers to cause a denial of service (memory corruption and QEMU crash) or possibly execute arbitrary code via a packet larger than 1514 bytes.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1599-1
Debian Bugs821061

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)buster, buster (security)1:3.1+dfsg-8+deb10u8fixed
bullseye1:5.2+dfsg-11+deb11u1fixed
bullseye (security)1:5.2+dfsg-11+deb11u2fixed
bookworm, sid1:7.0+dfsg-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusourcejessie1:2.1+dfsg-12+deb8u8DLA-1599-1
qemusource(unstable)1:2.6+dfsg-2821061
qemu-kvmsource(unstable)(unfixed)

Notes

[wheezy] - qemu <no-dsa> (Minor issue)
[wheezy] - qemu-kvm <no-dsa> (Minor issue)
https://bugzilla.redhat.com/show_bug.cgi?id=1326082
https://lists.gnu.org/archive/html/qemu-devel/2016-04/msg01131.html
https://www.openwall.com/lists/oss-security/2016/04/11/6

Search for package or bug name: Reporting problems