CVE-2016-4036

NameCVE-2016-4036
DescriptionThe quagga package before 0.99.23-2.6.1 in openSUSE and SUSE Linux Enterprise Server 11 SP 1 uses weak permissions for /etc/quagga, which allows local users to obtain sensitive information by reading files in the directory.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-601-1, DSA-3654-1
NVD severitylow (attack range: local)
Debian Bugs835223

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
quagga (PTS)wheezy0.99.22.4-1+wheezy2vulnerable
wheezy (security)0.99.22.4-1+wheezy3+deb7u2fixed
jessie (security), jessie0.99.23.1-1+deb8u4fixed
stretch (security), stretch1.1.1-3+deb9u1fixed
buster, sid1.2.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
quaggasource(unstable)1.0.20160315-2low835223
quaggasourcejessie0.99.23.1-1+deb8u2lowDSA-3654-1
quaggasourcewheezy0.99.22.4-1+wheezy3lowDLA-601-1

Notes

https://bugzilla.suse.com/show_bug.cgi?id=770619
World readable files in /etc/quagga as well in Debian

Search for package or bug name: Reporting problems