CVE-2016-4052

NameCVE-2016-4052
DescriptionMultiple stack-based buffer overflows in Squid 3.x before 3.5.17 and 4.x before 4.0.9 allow remote HTTP servers to cause a denial of service or execute arbitrary code via crafted Edge Side Includes (ESI) responses.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-478-1, DSA-3625-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
squid (PTS)wheezy2.7.STABLE9-4.1+deb7u1fixed
wheezy (security)2.7.STABLE9-4.1+deb7u2fixed
squid3 (PTS)wheezy3.1.20-2.2+deb7u4vulnerable
wheezy (security)3.1.20-2.2+deb7u7fixed
jessie (security), jessie3.4.8-6+deb8u4fixed
buster, sid, stretch3.5.23-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
squidsource(unstable)(not affected)
squid3source(unstable)3.5.17-1medium
squid3sourcejessie3.4.8-6+deb8u3mediumDSA-3625-1
squid3sourcewheezy3.1.20-2.2+deb7u5mediumDLA-478-1

Notes

- squid <not-affected> (Squid 2.x are not vulnerable)
http://www.squid-cache.org/Advisories/SQUID-2016_6.txt
http://www.squid-cache.org/Versions/v3/3.2/changesets/squid-3.2-11841.patch (Squid 3.2)
http://www.squid-cache.org/Versions/v3/3.3/changesets/squid-3.3-12697.patch (Squid 3.3)
http://www.squid-cache.org/Versions/v3/3.4/changesets/squid-3.4-13235.patch (Squid 3.4)
http://www.squid-cache.org/Versions/v3/3.5/changesets/squid-3.5-14034.patch (Squid 3.5)

Search for package or bug name: Reporting problems