CVE-2016-4085

NameCVE-2016-4085
DescriptionStack-based buffer overflow in epan/dissectors/packet-ncp2222.inc in the NCP dissector in Wireshark 1.12.x before 1.12.11 allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a long string in a packet.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-497-1, DSA-3585-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)wheezy1.8.2-5wheezy18vulnerable
wheezy (security)1.12.1+g01b65bf-4+deb8u6~deb7u7fixed
jessie1.12.1+g01b65bf-4+deb8u11fixed
jessie (security)1.12.1+g01b65bf-4+deb8u12fixed
stretch2.2.6+g32dac6a-2fixed
stretch (security)2.2.6+g32dac6a-2+deb9u1fixed
buster, sid2.4.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksource(unstable)2.0.0~rc2+g74e5b56-1medium
wiresharksourcejessie1.12.1+g01b65bf-4+deb8u6mediumDSA-3585-1
wiresharksourcewheezy1.12.1+g01b65bf-4+deb8u6~deb7u1mediumDLA-497-1

Notes

https://www.wireshark.org/security/wnpa-sec-2016-28.html
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=12293
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=12293
Doesn't affect 2.x series

Search for package or bug name: Reporting problems