CVE-2016-4414

NameCVE-2016-4414
DescriptionThe onReadyRead function in core/coreauthhandler.cpp in Quassel before 0.12.4 allows remote attackers to cause a denial of service (NULL pointer dereference and crash) via invalid handshake data.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs826402

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
quassel (PTS)stretch (security), stretch1:0.12.4-2+deb9u1fixed
buster1:0.13.1-1+deb10u2fixed
bullseye, sid1:0.13.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
quasselsource(unstable)1:0.12.4-2826402
quasselsourcejessie1:0.10.0-2.3+deb8u3
quasselsourcewheezy(not affected)

Notes

[wheezy] - quassel <not-affected> (Vulnerable code introduced with 0.10.0)
https://github.com/quassel/quassel/blob/f64ac93/src/core/coreauthhandler.cpp#L100
Introduced by: https://github.com/quassel/quassel/commit/d1bf207 (0.10.0)
Fixed by: https://github.com/quassel/quassel/commit/e67887343c433cc35bc26ad6a9392588f427e746 (0.12.4)
http://www.openwall.com/lists/oss-security/2016/04/30/2

Search for package or bug name: Reporting problems