CVE-2016-4425

NameCVE-2016-4425
DescriptionJansson 2.7 and earlier allows context-dependent attackers to cause a denial of service (deep recursion, stack consumption, and crash) via crafted JSON data.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-471-1, DSA-3577-1
NVD severitymedium (attack range: remote)
Debian Bugs823238

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
jansson (PTS)wheezy2.3.1-2vulnerable
wheezy (security)2.3.1-2+deb7u1fixed
jessie (security), jessie2.7-1+deb8u1fixed
stretch2.9-1fixed
buster, sid2.10-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
janssonsource(unstable)2.7-5medium823238
janssonsourcejessie2.7-1+deb8u1mediumDSA-3577-1
janssonsourcewheezy2.3.1-2+deb7u1mediumDLA-471-1

Notes

https://github.com/akheron/jansson/issues/282
https://github.com/akheron/jansson/pull/284
http://www.openwall.com/lists/oss-security/2016/05/01/5

Search for package or bug name: Reporting problems