CVE-2016-4428

NameCVE-2016-4428
DescriptionCross-site scripting (XSS) vulnerability in OpenStack Dashboard (Horizon) 8.0.1 and earlier and 9.0.0 through 9.0.1 allows remote authenticated users to inject arbitrary web script or HTML by injecting an AngularJS template in a dashboard form.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-520-1, DSA-3617-1
NVD severitylow (attack range: remote)
Debian Bugs828967

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
horizon (PTS)wheezy2012.1.1-10vulnerable
wheezy (security)2012.1.1-10+deb7u1fixed
jessie (security), jessie2014.1.3-7+deb8u2fixed
sid, stretch3:10.0.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
horizonsource(unstable)3:9.0.1-2low828967
horizonsourcejessie2014.1.3-7+deb8u2lowDSA-3617-1
horizonsourcewheezy2012.1.1-10+deb7u1lowDLA-520-1

Notes

https://bugs.launchpad.net/bugs/1567673

Search for package or bug name: Reporting problems