CVE-2016-4447

NameCVE-2016-4447
DescriptionThe xmlParseElementDecl function in parser.c in libxml2 before 2.9.4 allows context-dependent attackers to cause a denial of service (heap-based buffer underread and application crash) via a crafted file, involving xmlParseName.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-503-1, DSA-3593-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxml2 (PTS)wheezy2.8.0+dfsg1-7+wheezy5vulnerable
wheezy (security)2.8.0+dfsg1-7+wheezy9fixed
jessie2.9.1+dfsg1-5+deb8u4fixed
jessie (security)2.9.1+dfsg1-5+deb8u5fixed
stretch (security), stretch2.9.4+dfsg1-2.2+deb9u1fixed
buster2.9.4+dfsg1-4fixed
sid2.9.4+dfsg1-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxml2source(unstable)2.9.3+dfsg1-1.1medium
libxml2sourcejessie2.9.1+dfsg1-5+deb8u2mediumDSA-3593-1
libxml2sourcewheezy2.8.0+dfsg1-7+wheezy6mediumDLA-503-1

Notes

https://bugzilla.gnome.org/show_bug.cgi?id=759573
https://git.gnome.org/browse/libxml2/commit/?id=00906759053986b8079985644172085f74331f83 (v2.9.4)

Search for package or bug name: Reporting problems