CVE-2016-4476

NameCVE-2016-4476
Descriptionhostapd 0.6.7 through 2.5 and wpa_supplicant 0.6.7 through 2.5 do not reject \n and \r characters in passphrase parameters, which allows remote attackers to cause a denial of service (daemon outage) via a crafted WPS operation.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-473-1
NVD severitymedium
Debian Bugs823411

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wpa (PTS)stretch2:2.4-1+deb9u6fixed
stretch (security)2:2.4-1+deb9u7fixed
buster2:2.7+git20190128+0c1e29f-6+deb10u2fixed
buster (security)2:2.7+git20190128+0c1e29f-6+deb10u1fixed
bullseye2:2.9.0-15fixed
sid2:2.9.0-16fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wpasourcewheezy1.0-3+deb7u4DLA-473-1
wpasourcejessie2.3-1+deb8u4
wpasource(unstable)2.3-2.4823411

Notes

http://w1.fi/security/2016-1/

Search for package or bug name: Reporting problems