CVE-2016-4478

NameCVE-2016-4478
DescriptionBuffer overflow in the xmlrpc_char_encode function in modules/transport/xmlrpc/xmlrpclib.c in Atheme before 7.2.7 allows remote attackers to cause a denial of service via vectors related to XMLRPC response encoding.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3586-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
atheme-services (PTS)jessie (security), jessie6.0.11-2+deb8u1fixed
buster, sid, stretch7.2.9-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
atheme-servicessource(unstable)7.0.7-2medium
atheme-servicessourcejessie6.0.11-2+deb8u1mediumDSA-3586-1

Notes

https://github.com/atheme/atheme/commit/87580d767868360d2fed503980129504da84b63e
http://www.openwall.com/lists/oss-security/2016/05/02/2

Search for package or bug name: Reporting problems