CVE-2016-4561

NameCVE-2016-4561
DescriptionCross-site scripting (XSS) vulnerability in the cgierror function in CGI.pm in ikiwiki before 3.20160506 might allow remote attackers to inject arbitrary web script or HTML via unspecified vectors involving an error message.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-463-1, DSA-3571-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ikiwiki (PTS)wheezy3.20120629.2vulnerable
wheezy (security)3.20120629.2+deb7u2fixed
jessie (security), jessie3.20141016.4fixed
buster, stretch3.20170111fixed
sid3.20170622fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ikiwikisource(unstable)3.20160506medium
ikiwikisourcejessie3.20141016.3mediumDSA-3571-1
ikiwikisourcewheezy3.20120629.2+deb7u1mediumDLA-463-1

Notes

http://source.ikiwiki.branchable.com/?p=source.git;a=commitdiff;h=32ef584dc5abb6ddb9f794f94ea0b2934967bba7
http://www.openwall.com/lists/oss-security/2016/05/06/8

Search for package or bug name: Reporting problems