CVE-2016-4566

NameCVE-2016-4566
DescriptionCross-site scripting (XSS) vulnerability in plupload.flash.swf in Plupload before 2.1.9, as used in WordPress before 4.5.2, allows remote attackers to inject arbitrary web script or HTML via a Same-Origin Method Execution (SOME) attack.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs823640

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)stretch (security), stretch4.7.5+dfsg-2+deb9u6fixed
buster, buster (security)5.0.10+dfsg1-0+deb10u1fixed
bullseye, sid5.4.2+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssourcewheezy(not affected)
wordpresssourcejessie(not affected)
wordpresssource(unstable)4.5.2+dfsg-1823640

Notes

[jessie] - wordpress <not-affected> (Vulnerable code not present)
[wheezy] - wordpress <not-affected> (Vulnerable code not present)
https://wordpress.org/news/2016/05/wordpress-4-5-2/
Fixed by: https://core.trac.wordpress.org/changeset/37382
http://www.openwall.com/lists/oss-security/2016/05/07/2

Search for package or bug name: Reporting problems