CVE-2016-4738

NameCVE-2016-4738
Descriptionlibxslt in Apple iOS before 10, OS X before 10.12, tvOS before 10, and watchOS before 3 allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted web site.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-700-1, DSA-3709-1
NVD severityhigh (attack range: remote)
Debian Bugs842570

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxslt (PTS)wheezy1.1.26-14.1vulnerable
wheezy (security)1.1.26-14.1+deb7u3fixed
jessie1.1.28-2+deb8u3fixed
jessie (security)1.1.28-2+deb8u2fixed
stretch1.1.29-2.1fixed
buster, sid1.1.29-2.2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxsltsource(unstable)1.1.29-2high842570
libxsltsourcejessie1.1.28-2+deb8u2highDSA-3709-1
libxsltsourcewheezy1.1.26-14.1+deb7u2highDLA-700-1

Notes

https://git.gnome.org/browse/libxslt/commit/?id=eb1030de31165b68487f288308f9d1810fed6880
https://bugs.chromium.org/p/chromium/issues/detail?id=619006

Search for package or bug name: Reporting problems