CVE-2016-4807

NameCVE-2016-4807
DescriptionWeb2py versions 2.14.5 and below was affected by Reflected XSS vulnerability, which allows an attacker to perform an XSS attack on logged in user (admin).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitylow (attack range: remote)
Debian Bugs856127

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
web2py (PTS)wheezy, jessie1.99.7-1vulnerable
sid2.12.3-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
web2pysource(unstable)(unfixed)low856127

Notes

[jessie] - web2py <no-dsa> (Minor issue; issue in web admin interface which has no need to be used in production)
[wheezy] - web2py <no-dsa> (Minor issue; issue in web admin interface which has no need to be used in production)
https://github.com/web2py/web2py/issues/1585
https://github.com/web2py/web2py/commit/51c3b633fe7ad647bc3013e899c1e3a910362dd1

Search for package or bug name: Reporting problems