CVE-2016-4808

NameCVE-2016-4808
DescriptionWeb2py versions 2.14.5 and below was affected by CSRF (Cross Site Request Forgery) vulnerability, which allows an attacker to trick a logged in user to perform some unwanted actions i.e An attacker can trick an victim to disable the installed application just by sending a URL to victim.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs856127

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
web2py (PTS)wheezy, jessie1.99.7-1vulnerable
sid2.12.3-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
web2pysource(unstable)(unfixed)medium856127

Notes

[jessie] - web2py <no-dsa> (Minor issue; issue in web admin interface which has no need to be used in production)
[wheezy] - web2py <no-dsa> (Minor issue; issue in web admin interface which has no need to be used in production)
https://github.com/web2py/web2py/issues/1585
https://github.com/web2py/web2py/commit/4bd002aee978813bc664cf186ef38ff4e8bbe1cd

Search for package or bug name: Reporting problems