CVE-2016-4957

NameCVE-2016-4957
Descriptionntpd in NTP before 4.2.8p8 allows remote attackers to cause a denial of service (daemon crash) via a crypto-NAK packet. NOTE: this vulnerability exists because of an incorrect fix for CVE-2016-1547.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ntp (PTS)jessie (security), jessie1:4.2.6.p5+dfsg-7+deb8u2fixed
stretch1:4.2.8p10+dfsg-3+deb9u2fixed
buster1:4.2.8p12+dfsg-4fixed
bullseye, sid1:4.2.8p13+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ntpsource(unstable)1:4.2.8p8+dfsg-1
ntpsourcejessie(not affected)
ntpsourcewheezy(not affected)

Notes

[jessie] - ntp <not-affected> (Fix for CVE-2016-1547 wasn't backported)
[wheezy] - ntp <not-affected> (Fix for CVE-2016-1547 wasn't backported)
http://support.ntp.org/bin/view/Main/SecurityNotice#June_2016_ntp_4_2_8p8_NTP_Securi
http://support.ntp.org/bin/view/Main/NtpBug3046

Search for package or bug name: Reporting problems