CVE-2016-4970

NameCVE-2016-4970
Descriptionhandler/ssl/OpenSslEngine.java in Netty 4.0.x before 4.0.37.Final and 4.1.x before 4.1.1.Final allows remote attackers to cause a denial of service (infinite loop).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs827620

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
netty (PTS)jessie1:3.2.6.Final-2fixed
jessie (security)1:3.2.6.Final-2+deb8u2fixed
stretch (security), stretch1:4.1.7-2+deb9u1fixed
buster, buster (security)1:4.1.33-1+deb10u1fixed
bullseye, sid1:4.1.33-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nettysource(unstable)1:4.0.37-1827620
nettysourcejessie(not affected)
nettysourcewheezy(not affected)

Notes

[jessie] - netty <not-affected> (Vulnerable code not present)
[wheezy] - netty <not-affected> (Vulnerable code not present)
Versions affected: Netty 4.0.0.Final - 4.0.36.Final and 4.1.0.Final

Search for package or bug name: Reporting problems