Descriptionhandler/ssl/ in Netty 4.0.x before 4.0.37.Final and 4.1.x before 4.1.1.Final allows remote attackers to cause a denial of service (infinite loop).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs827620

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
netty (PTS)buster1:4.1.33-1+deb10u2fixed
buster (security)1:4.1.33-1+deb10u3fixed
bullseye (security), bullseye1:4.1.48-4+deb11u1fixed
bookworm, sid1:4.1.48-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nettysourcewheezy(not affected)
nettysourcejessie(not affected)


[jessie] - netty <not-affected> (Vulnerable code not present)
[wheezy] - netty <not-affected> (Vulnerable code not present)
Versions affected: Netty 4.0.0.Final - 4.0.36.Final and 4.1.0.Final

Search for package or bug name: Reporting problems