CVE-2016-4971

NameCVE-2016-4971
DescriptionGNU wget before 1.18 allows remote servers to write to arbitrary files by redirecting a request from HTTP to a crafted FTP resource.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-536-1
NVD severitymedium (attack range: remote)
Debian Bugs827003

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wget (PTS)wheezy1.13.4-3+deb7u2vulnerable
wheezy (security)1.13.4-3+deb7u5fixed
jessie (security), jessie1.16-1+deb8u4fixed
stretch (security), stretch1.18-5+deb9u1fixed
buster, sid1.19.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wgetsource(unstable)1.18-1medium827003
wgetsourcejessie1.16-1+deb8u1medium
wgetsourcewheezy1.13.4-3+deb7u3mediumDLA-536-1

Notes

http://lists.gnu.org/archive/html/info-gnu/2016-06/msg00004.html
http://git.savannah.gnu.org/cgit/wget.git/commit/?id=e996e322ffd42aaa051602da182d03178d0f13e1 (v1.18)

Search for package or bug name: Reporting problems