CVE-2016-4994

NameCVE-2016-4994
DescriptionUse-after-free vulnerability in the xcf_load_image function in app/xcf/xcf-load.c in GIMP allows remote attackers to cause a denial of service (program crash) or possibly execute arbitrary code via a crafted XCF file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-525-1, DSA-3612-1
NVD severitymedium (attack range: remote)
Debian Bugs828179

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gimp (PTS)wheezy2.8.2-2+deb7u1vulnerable
wheezy (security)2.8.2-2+deb7u2fixed
jessie (security), jessie2.8.14-1+deb8u1fixed
stretch2.8.18-1fixed
buster, sid2.8.20-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gimpsource(unstable)2.8.16-2.2medium828179
gimpsourcejessie2.8.14-1+deb8u1mediumDSA-3612-1
gimpsourcewheezy2.8.2-2+deb7u2mediumDLA-525-1

Notes

https://bugzilla.gnome.org/show_bug.cgi?id=767873

Search for package or bug name: Reporting problems